lnmpa升级apache

今天又折腾了一下VPS,把apache升级到了2.2的最新版2.2.26。

#查看原来apache的编译参数
cat /usr/local/apache/build/config.nice

 

/etc/init.d/httpd stop #停止apache服务
#下载最新版2.2系列apache源码包
wget -c http://mirror.bit.edu.cn/apache//httpd/httpd-2.2.26.tar.gz
tar zxvf httpd-2.2.26.tar.gz #解压
cd httpd-2.2.26
#配置编译参数
./configure \
#安装路径
--prefix=/usr/local/apache \
#允许通过配置文件控制任意的HTTP请求和应答头信息
--enable-headers \
#开启mime-magic支持
--enable-mime-magic \
#开启代理/网关功能
--enable-proxy \
#开启so模块
--enable-so \
#开启URL重写
--enable-rewrite \
#开启SSL支持
--enable-ssl \
#开启压缩模块
--enable-deflate \
#开启suexec机制
--enable-suexec \
#在编译时强制使用当前源代码中绑定的APR版本
--with-included-apr \
#多处理模块,根据需要选择 worker 或 event 或 prefork
--with-mpm=prefork \ //prefork可靠性或者与旧软件兼容较好
#指定OpenSSL SSL/TLS工具包的位置
--with-ssl=/usr \
#禁止用户从自己的主目录中提供页面
--disable-userdir \
#禁止外部执行CGI脚本
--disable-cgid \
#禁止编译CGI
--disable-cgi \
#指定Expat的位置
--with-expat=builtin
#编译并安装
make && make install

这时apache已经安装好了,因为大版本没变,配置文件可以沿用原来的。
如果php不重新编译的话,在phpinfo显示的apache版本号还是原来的,有空最好重新编译一下。
我是直接用了军哥lnmp一键安装包里的升级脚本来重新编译,但是这个脚本中间有检测输入的版本号必须大于现有的版本号,同版本重新编译不了,必须把这里注释掉。

vi upgrade_lnmpa_php.sh

找到下面的代码,用#或//注释掉

	if [ "$php_version" = "$old_php_version" ]; then
		echo "Error: The upgrade PHP Version is the same as the old Version!!"
		exit 1
	fi

You might also like

Leave A Reply

Your email address will not be published.

This site uses Akismet to reduce spam. Learn how your comment data is processed.